Hinweis:Die Anleitungen auf dieser Seite beziehen sich ausschließlich auf BlueSpice 3.2.8. Sie werden obsolet, sobald Version 3.2.9 veröffentlicht ist!

Anwendung der MediaWiki 1.35.5 Sicherheitspatches auf BlueSpice 3[Bearbeiten | Quelltext bearbeiten]

Die letzten Sicherheitsfixes für MediaWiki 1.35 wurden auf MediaWiki 1.31 zurückportiert. MediaWiki 1.31 ist die Basis von BlueSpice 3.2. Die Patches stehen auf SourceForge zum Download bereit.

Die folgenden Anleitungen beziehen sich auf Linux-Installationen. Sie können aber auf einem Windows-System mit einer entsprechenden Shell auf die gleiche Weise ausgeführt werden, z.B. git bash, cygwin und ähnliche.

Vorausgesetzt, dass <bluespice> der Installationspfad der BlueSpice-Anwendung ist, können Sie die Patches wie folgt anwenden:

cd <bluespice>/_bluespice
wget https://sourceforge.net/projects/bluespice/files/BlueSpice-3.2.8-MW1.35.5-fixes.tar.gz
tar xfvz BlueSpice-3.2.8-MW1.35.5-fixes.tar.gz
cd ..
bash _bluespice/pre-autoload-dump.d/99-apply_patches.sh

Nach einer erfolgreichen Durchführung sollte die Ausgabe so aussehen:

Patching: includes/actions/RollbackAction.php ==> DONE!
Patching: includes/actions/Action.php ==> DONE!
Patching: includes/actions/ViewAction.php ==> DONE!
Patching: includes/specials/SpecialChangeContentModel.php ==> DONE!
Patching: includes/MediaWiki.php ==> DONE!
Patching: includes/EditPage.php ==> DONE!
Patching: extensions/VisualEditor/modules/ve-mw/ui/dialogs/ve.ui.MWMediaDialog.js ==> DONE!

Je nach Edition von BlueSpice können zusätzliche Ausgabezeilen vorhanden sein.

Keine Kategorien vergebenBearbeiten

Diskussionen

Anhänge