PluggableAuth


PluggableAuth
Ergänzt ein Framework zur Authentifikation und Autorisierung
Status: stable
Entwickler: Cindy Cicalese
Art der Extension: MediaWiki
Edition: BlueSpice
Abhängigkeit: MediaWiki
Lizenz: MIT
Aktiviert: Nein
Kategorie: Infrastruktur
Dokumentation auf MediaWiki.org

Die Erweiterung PluggableAuth bietet ein Framework für die Erstellung von Authentifizierungs- und Autorisierungserweiterungen. PluggableAuth stellt den Code zur Verfügung, der für die Implementierung dieser Erweiterungen erforderlich ist und ist besonders nützlich für den Einsatz mit Enterprise-Authentifizierungsservern, die über mehrschichtige Mechanismen wie OpenID Connect oder SimpleSAMLphp angesprochen werden. Authentifizierungserweiterungen sind eine Unterklasse der abstrakten Klasse PluggableAuth. Da viele Wiki-Administratoren den Zugriff auf eine Teilmenge aller authentifizierten Benutzer beschränken möchten, bietet PluggableAuth einen Autorisierungs-Hook, PluggableAuthUserAuthorization. Um die Gruppeninformationen von MediaWiki um die von einem externen Anbieter zu ergänzen, stellt PluggableAuth den PluggableAuthPopulateGroups-Hook zur Verfügung.

Für weitere Informationen besuchen Sie bitte MediaWiki.


Icon-link.png

Verwandte Themen

Anhänge

Diskussionen