Setup:Systemanforderungen: Unterschied zwischen den Versionen

 
Zeile 9: Zeile 9:
 
==Serverumgebung==
 
==Serverumgebung==
 
{{Hinweisbox|boxtype=warning|icon=yes|Note text=PHP '''Version 8.1''' wird derzeit nicht unterstützt!|bgcolor=}}
 
{{Hinweisbox|boxtype=warning|icon=yes|Note text=PHP '''Version 8.1''' wird derzeit nicht unterstützt!|bgcolor=}}
* Betriebssystem: Linux (vorzugsweise Ubuntu oder Debian),  Microsoft Windows Server >= 2016 möglich, aber geringere Performanz
+
* Betriebssystem: Linux empfohlen (vorzugsweise Ubuntu oder Debian),  Microsoft Windows Server >= 2016 möglich, aber geringere Performanz
 
*Webserver: Apache 2.4.x, IIS >= 10  ''oder'' nginx 1.x (''nginx'' ''in WikiFarm nicht möglich)''
 
*Webserver: Apache 2.4.x, IIS >= 10  ''oder'' nginx 1.x (''nginx'' ''in WikiFarm nicht möglich)''
 
* PHP 7.4.x ab 7.4.3 oder PHP 8.0
 
* PHP 7.4.x ab 7.4.3 oder PHP 8.0

Aktuelle Version vom 23. November 2022, 14:15 Uhr

Für den problemlosen Betrieb in der aktuellen Version von BlueSpice 4 empfehlen wir die folgenden Systemanforderungen. Die Anwendung von BlueSpice wird von Hallo Welt! unter Windows und Linux getestet.

Browser[Bearbeiten | Quelltext bearbeiten]

  • Microsoft Edge
  • Google Chrome
  • Firefox

Serverumgebung[Bearbeiten | Quelltext bearbeiten]

Achtung!PHP Version 8.1 wird derzeit nicht unterstützt!
  • Betriebssystem: Linux empfohlen (vorzugsweise Ubuntu oder Debian), Microsoft Windows Server >= 2016 möglich, aber geringere Performanz
  • Webserver: Apache 2.4.x, IIS >= 10 oder nginx 1.x (nginx in WikiFarm nicht möglich)
  • PHP 7.4.x ab 7.4.3 oder PHP 8.0
  • MySQL: >= 5.6 oder MariaDB >= 10.3
  • Hauptspeicher: 16 GB (minimal 8 GB)
  • Freier Festplattenspeicher: > 20 GB
  • CPU: 8 (minimal 4) Kerne
  • Apache Tomcat >= 9 oder Jetty >= 9
  • ElasticSearch 6.8 mit Plugin “ingest-attachment”
  • OpenJDK >= 10
  • NodeJS 16

Diskussionen